Node falling out of sync

Hello, I've observed that my node has been falling out of sync for a few days now and was wondering if anyone would be able to offer some help or advise. I've tried restarting the node software and restaring the server I run on. I have enable_control disabled in my configuration, but aside from that it should be default to the best of my knowledge. Cementing blocks seem to have come to a near stand still and I've observed this only increase by a single digit over the space of an hour. This is the first time I have noticed this occurance. I have noticed there is a pending recieve transaction from around when the issue started, but I assume this is unrelated.

current block_count rpc output:
count: 50052037
unchecked: 1277444
cemented: 49863749

Node version: Nano V21.0

I run on a VPS from Hetzner with 4vCPU, 16GB Ram, 160GB Disk, 20TB Traffic.

Any help, thoughts or advice appreciated!

Hey there @HarryHazel !

If this is still ocurring, could you please provide the output of RPC confirmation_quorum.

If you see peers_stake_total lower than peers_stake_required , feel free to stop the node, run CLI --peer_clear and then restart it normally, waiting 30 minutes before checking the previous RPC again.

Hi @Dotcom and thank you for the suggestion! I have pasted the before and after confirmation_quorum below, however it appeared the peers_stake_total was higher than peers_stake_required, so unfortunately still appears to have the same issue of cementing blocks very slowly.

Before:
"quorum_delta": "34023562201751783180378132157238471700",
"online_weight_quorum_percent": "50",
"online_weight_minimum": "60000000000000000000000000000000000000",
"online_stake_total": "68047124403503566360756264314476943448",
"peers_stake_total": "87614614599300026707628065889672000866",
"peers_stake_required": "60000000000000000000000000000000000000"

After running --peer_clear and waiting 30 minutes:
"quorum_delta": "34044041095014529296714589324573236250",
"online_weight_quorum_percent": "50",
"online_weight_minimum": "60000000000000000000000000000000000000",
"online_stake_total": "68088082190029058593429178649146472591",
"peers_stake_total": "87536028662829743867875195955356971515",
"peers_stake_required": "60000000000000000000000000000000000000"

My block_count output is:
Count: 50059411
Unchecked: 1337846
Cemented: 49864114

Is there any other debugging you think might be useful to begin figuring out where the problem may be?

Hi @HarryHazel - have you been able to make progress here? We are looking into a few things which might help and hope to provide details shortly, but hopefully you aren't still blocked.

It looks like you’re still bootstrapping. If you still have unchecked blocks, try running it with --disable_lazy_bootstrap until it’s finished bootstrapping and then start it as usual once it’s done.

If you haven't been able to fully bootstrap yet you could be facing one of the issues identified and resolved in the upcoming V21.1 release, which is now available as a release candidate on beta: https://github.com/nanocurrency/nano-node/releases/tag/V21.1RC1.

If you'd like to run this prior to general availability, you can build from the related tag or run one of the RC binaries with the --network launch flag (see https://docs.nano.org/commands/command-line-interface/#-network). Let us know if you have questions about this.

1 Like