Docker container doesn't start


I have ran a node before, but this is the first time I'm using docker. I'm following the manual, but when I try to start the container, it keeps restarting forever and the only thing I see in the logs is:

standard_init_linux.go:211: exec user process caused "exec format error"

And the docker ps shows:

CONTAINER ID        IMAGE                      COMMAND                  CREATED             STATUS                          PORTS               NAMES
c82bbdced37f        nanocurrency/nano:latest   "/bin/bash /usr/bin/…"   14 minutes ago      Restarting (1) 54 seconds ago                       nano

I'm not very familiar with Docker, but I suppose this is a container problem?

If this is not the right place to ask, please let me know where is.

Most node operators hang out on Discord where chat/support can happen more real time. If you haven’t tried there already I would suggest posting this in the #support channel.

Thanks, I wanted to try this "official" channel first, I'll give the possibilities you listed a try.

what does your docker run command look like?
What OS are you hosting this on, what version of Docker?
are you able to run docker run --rm -it nanocurrency/nano nano_node --version or does this error out as well?
it may also be worth while to try deleting the image locally and then downloading a new one

*edit typo in docker container reference

the run command looked like:
sudo docker run --restart=unless-stopped -d -p 7075:7075/udp -p 7075:7075 -p [::1]:7076:7076 -p [::1]:7078:7078 -v /media/share/nano:/root --name nano nanocurrency/nano:latest

The OS is Raspbian GNU/Linux 9 (stretch), running on ARM.

The command you wrote is giving me "repository does not exist", but when I try:
docker run --rm -it nanocurrency/nano nano_node --version
then I get the same error.

I don't think the official docker has been compiled to run under ARM processor. I could be wrong but I think you have to compile the node yourself to run on a raspbian and that is not super easy. I know people have done it in the past, try this: