Can't create nano-vanity address with AMD GPU?

Hi All,

I'm trying to set up a PR, but since I'm vain, I'd like a nano-vanity address as the PR address!
I've noted my current issues in the github repo.

I'm trying to set up an 8 character prefix and my CPU would take months to generate this, I do have that chugging away anyways, but really want to get this address ASAP.

Hope someone can chime in. Thanks!

Hey, I saw your GitHub comment, sorry I didn't get back to you there. IDK what the OpenCL you grabbed was for, but I'd recommend using the one that should come with your GPU drivers. I'd try searching your C drive for an opencl.dll file. Most likely, the AMD drivers included one, but it wasn't found during compilation.

Unfortunately, you may face issues even after getting the correct OpenCL, e.g. https://github.com/PlasmaPower/nano-vanity/issues/33 . OpenCL is kind of a mess.

1 Like

Hey! It's ok, we're all busy :slight_smile:

So, I found a few openCl.dll files and one that appears to be from AMD named "AMD_OpenCL64.dll"

Do I need to tell rust or nano-vanity where to look for this? If so, may you kindly provide an example of the command I need? I can take that and test nano-vanity with each of the .dll files I have and maybe I'll get lucky and find the one that works. I'd like to exhaust all my options before giving up. Thank you!

It should come with your driver, so I'd recommend searching your C drive for any files with OpenCL in their name and an extension of DLL (I think the windows file explorer supports both of those).

I think you might need to put it somewhere in your PATH. Maybe the directory you're compiling from, or you could create a folder somewhere, add that to your PATH, and put the DLL in there.

I found the following opencl dll file that seemed related to my gpu. I moved that file into the nano-vanity folder where I then build/install nano-vanity & run it with a -g tag. No go.

C:\AMD\Packages\Drivers\Radeon-Software-Adrenalin-2019-19.8.2-u0346134-win10-64bit-190826\B346122\amd_opencl64.dll

In the issue I raised on your git, I link to another github which gave me
C:\Program Files (x86)\OCL_SDK_Light\lib\x86_64\opencl.lib I tried the same as above, but did not succeed.

The OCL SDK has the following README that seems informative but I'm not sure where to modify your project to include this. If you have any suggestions, please chime in!

This light SDK for OpenCL only installs the required component to compile an OpenCL program It also creates the following environment variable OCL_ROOT which points to the installation path of this SDK To include the headers and library in your project, you can then use the following ${OCL_ROOT}\include ${OCL_ROOT}\lib\x86 ${OCL_ROOT}\lib\x86_64

I also foundthis other github which seems to have AMD support.
I'll report back if I make any progress.

The first one's what you want. The other opencl you installed might be taking priority though.

Ok, so I had a few other GPU drivers installed.
I went ahead and ran DDU in safe mode to remove all drivers I had. There was one persistent driver that I could not get rid of even after multiple DDU attempts. I just left that there.


Sry for the pic of comp, couldn't figure out how to save screenshots in safe mode.

I then reinstalled the recommended AMD drivers and tried again... No go.

Do you think I'd have better luck if I ran your code in a linux virtualbox?

I got lucky enough to find a vanity through CPU that is VERY close to my name, "robocazh" instead of "robocash". If I can't easily solve this GPU issue, I might just wave the white flag and take what I can get....

A virtualbox instance won't have access to your GPU unfortunately.

I've got some spare SSDs sitting in my HDD bay. I can format one of them into Linux and set up a dual-boot system.

If I can boot into a linux distro, do you think that would help with my issue?

That option will work because it's not virtualized. Maybe you end up staying on Linux permanently :face_with_hand_over_mouth:

If it's a spare disk, the dual-boot is easy. If you want to be as safe as possible, I suggest disabling / disconnecting your main disk to avoid overwriting it.

You might like the bootable USB stick option too: https://tutorials.ubuntu.com/tutorial/tutorial-create-a-usb-stick-on-windows

Cool. I managed to get mint 19.2 up and running, but having trouble with either my openCL drivers there or it's the fact that I cannot seem to get my kernel to upgrade beyond 5.3.0.

Such a pain!