Can not access coins on


I have serious issue accessing my coins on because i lost my seed. I hope that someone from devs can provide assistance with this situation.
I understand that this is a delicate matter because I should have taken care of my seed, but I know amount of nanos that i have on wallet and hopefully will be able to prove that I am rightful owner.

I am looking forward to hearing from you and please let me know is there any way this can be solved.

Thank you

Hi Luka, have you read this announcement from the team at Nanowallet yet and tried to contact the support email listed within?

Hi Andy,

Thank you for quick reply. I have read announcement and contacted NanoWallet support via e-mail four days ago but received no response yet.

I am having the same issue. I have my wallet identifier, 2FA, email, wallet address..pretty much everything. I have tried all of my passwords, but I can't get into nanowallet to retrieve the seed. It's really frustrating. The support team has not responded to my emails.

Hello Andy, can you help in any other way? I still can not establish contact with nano wallet support team. Do you have any other contact to provide or direction what to do?

Thank you

Here is the Reddit announcement, perhaps you can contact via Dm there?