Account hasn’t been opened yet - from Binance to Trust Wallet

I have seen this question asked over and over again on various forums - but have not seen any clear answer ever given.

I am brand new to crypto investing/collecting and I don’t have familiarity with a lot of the terms or acronyms people are throwing around - so please keep that in mind if you reply to try and help me.

  1. I have had a Binance account for a couple of months and have bought a few different currencies including Nano.

  2. Today I installed the Trust Wallet on my iOS device and created a multi-currency wallet.

  3. As a test, I tried to withdraw 16.49 Nano from my Binance account. To do this, in the Trust app, I added Nano to my wallet and chose “Receive”. I then copied the receive address. In Binance, I pasted the address in. The network showed Nano and was grayed out so it couldn’t be changed. I clicked Withdraw and then did other stuff for an hour. After an hour, I checked my Trust Wallet and it was still empty.

  4. I went back to Binance and the transaction said Processing (0/1). I checked Explorer and see that:

  • There is a TXID.
  • A send notice saying that the Block is confirmed on the network
  1. The block is:
    F6BC83A35DC91EFCA51F7EFD1AFB512E60BCEBD3E7687E7B97274E19ED56D886

  2. My receive address is:
    nano_344t4jpdzoudjrecfzya1mxnor1c4zrecj4stzndj74y8gxtsimw8hoe8e98

When I click on the receive address I see the message:

While the account address is valid, no blocks have been published to its chain yet. If NANO has been sent to this account, it still needs to publish a corresponding block to pocket the funds.

This message makes me think that I need to actively do something to accept the transfer. Is that true? Do I? It has been over 2 hours since the transfer was sent? What could be wrong? Is there anything I need to do within the wallet to receive it? Why is it taking so long?

  1. After an hour and a half, I tried sending 100 Dogecoin from Binance to the same Trust multi-wallet. The Dogecoing transfer was successful in less than 2 minutes. (So I know the Trust wallet itself is working)

Is there anything else I can post that will help troubleshoot or resolve this problem ?

1 Like

Same problem , waiting for the solution .

Well... I don't know how Trust Wallet works, if it generates a private key or if it asks binance to do so...
anyway, the wallet should create a receive block as soon as it sees the send block on the network.
For me it means the node you wallet is connected has not downloaded the "send" block yet, so your wallet doesn't know there's funds to be pocketed.
I use Natrium for mobile and Nault for desktop, connected to Natrium nodes and nanolooker respectively.
I'd contact the Trust Wallet guys to check how their servers are doing. Because both nano crawler and nano looker report the send block as confirmed, your wallet should've created a receive block already.

Thanks for your reply.

I just created a Trust forum account and I’ve copied and pasted this same message to their support forum - but apparently it’s being held for review and manual approval.

If they say anything useful - I’ll come back here and update this post with the solution.

My Nano showed up a few minutes ago when I opened the Trust wallet to check for it. A few seconds after opening the app, I also got the confirmation alert from Binance that said my withdrawal had been claimed.

I suspect that someone at Trust or Nano used the information in my post to fix the problem - but nobody has admitted to it.

If you’re having the same problem, I’d suggest you post the receive address and block to both forums and see if that helps get your Nano unstuck...

Sorry I wasn’t able to get an explanation for why it took 30 hours to show up. Good luck to anyone else in the same boat.

I heard their servers are far behind on network synchronization.

i am having the same problem. this is my wallet code: nano_3ic7yezf67kp4nsj73inygkxz6ddpfyysit3zatbawqqpyqbcatw5ym4r989
This is so ridiculous and really annoying. you aim to be a fast payment tool, but for some reason, transactions stay pending hours. 2 transaction pending

whose? binance or trust wallet

You can check your seed in Trust Wallet and import it into https://nault.cc/ :slight_smile: